Ошибка: неверный логин FTP
Эта ошибка возникает, когда конструктор сайта не может аутентифицироваться с FTP-аккаунтом на вашем хостинг-аккаунте. Способ решения зависит от панели управления хостингом — также за этим могут стоять несколько общих причин.
Общие причины
-
FTP-сервис не запущен на сервере.
Чтобы решить эту проблему, включите FTP-сервис на вашем хостинг-сервере. -
Ваш FTP-сервер может принимать только SSL-соединения.
Чтобы решить эту проблему, выполните следующие действия:- Перейдите на страницу лицензий.
- Разверните бренд, нажав кнопку «Управление».
- Перейдите в раздел «Конфигурация» слева.
- Найдите опцию «Использовать защищённый FTP» и измените её на «Да».
- Сохраните изменения, нажав кнопку «Применить» внизу диалога.
-
Ваш FTP-сервер может использовать нестандартный порт вместо порта 21 по умолчанию.
Чтобы решить эту проблему, выполните следующие действия:- Перейдите на страницу лицензий.
- Разверните бренд, нажав кнопку «Управление».
- Перейдите в раздел «Конфигурация» слева.
- Найдите опцию «Пользовательский FTP-порт» и измените порт на тот, который использует ваш FTP-сервис.
- Сохраните изменения, нажав кнопку «Применить» внизу диалога.
cPanel
Метод 1 — если ошибка появляется при открытии конструктора сайта из WHMCS или WHM под администратором:
- Войдите на сервер cPanel через SSH.
- Удалите файл
/home/[user]/.spbldr_localStorage(этот файл создаётся плагином конструктора сайта). - Если удаляете через Файловый менеджер cPanel, сначала включите «Показывать скрытые файлы (dotfiles)» в настройках (в правом верхнем углу), так как dotfiles по умолчанию не отображаются.
- Удалите все FTP-аккаунты с именами пользователей в формате «a1b2c3d4@domain.com» (они создаются плагином конструктора сайта).
- Снова откройте конструктор сайта из WHMCS или WHM и опубликуйте сайт, чтобы убедиться, что проблема решена.
Метод 2 — если ошибка появляется при открытии конструктора сайта из личного аккаунта cPanel клиента:
- Войдите в WHM.
- Найдите пострадавшего клиента на странице «Список аккаунтов».
- Измените пароль клиента (можно сбросить на тот же, что был).
- Снова откройте конструктор сайта из аккаунта cPanel клиента и опубликуйте сайт, чтобы проверить, решена ли проблема.
ISPmanager
- Попробуйте удалить FTP-аккаунт(ы) пользователя с именем в формате
s[8-значный-хэш](например, «s1a2b3c4d»). Они создаются автоматически плагином конструктора сайта. - Снова откройте конструктор из ISPmanager и опубликуйте сайт, чтобы проверить, решена ли проблема.